Pages

Saturday, May 02, 2015

VIPRE Agent "Not Communicating" after 1 - 5 days



VIPRE admin console will start reporting agents with a status of "Not Communicating" after 1 - 5 days.  Restarting the computer will change the status from "Not Communicating" to "Protected" but the issue will come back anywhere from 1 - 5 days after the restart.  This is a known issue, and there are 2 ways to fix this:

1. Use the Private Release

Issue is fixed in a private release (VIPRE Agent 7.0.5746)

To apply the patch do the following.

1. Open the VIPRE Business Console
2. Open Site Properties and select "Updates"
3. Uncheck "Automatically download Agent Software Updates"
4. Apply the change, select OK, and close the Console
5. Stop the VIPRE Business Premium Site Service
6. Download the Private Release below:

Note To find out if you are running standard or premium, go to the list of agents, right-click on the affected machine and choose Agent Details.  Near the upper left, you will see the Agent Type.

7. Save & Replace the file(s) in the Volatile Data's SoftwareUpdate folder:
  • C:\ProgramData\VIPRE Business\SoftwareUpdate (Default)
8. Start the VIPRE Business Site Service

Once finished, deploy the Private Release agent to affected machines. 


2. Workaround: can be applied to 7.0.5711 and 7.05725 agent if upgrading is not desired.
  • Set AP to "Execution Only" (Confirm End-Users don't control AP
  • Ensure all Email Clients are Unchecked inside Email Protection 
  • Ensure Email Client Ports are both set to "0
  • Close all instances of Outlook and unregister VIPRE's "SBAMOutlook.dll" file 

Note: All users must have outlook closed to unregister "SBAMOutlook.dll"  If possible perform these steps when no one is logged into the machine.

Unregistering VIPRE's SBAMOutlook.dll:
  1. If possible: Log-out all other users 
  2. Close Outlook, if it's open 
  3. Open an Administrative Command Prompt 
  4. Change Directory to the Agent's Installation Folder 
  5. Run the following command: regsvr32 /u 'C:\Program files (x86)\VIPRE Business Agent\SBAMOutlook.dll" 


Note: There should be a dialog confirming success

No comments: